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Добро пожаловать в Rational ClearQuest

ClearQuest – это настраиваемая система прослеживания дефектов и изменений, предназначенная для динамической среды разработки программного обеспечения. Используя ClearQuest, Вы можете управлять любым типом действий изменения, связанного с разработкой программного обеспечения, включая запросы расширения, отчеты о дефектах и модификацию документации.
ClearQuest сокращает время разработки, объединяя всю вашу группу в процессе управления изменениями программного обеспечения:
· Разработчики могут идентифицировать и располагать по приоритетам элементы действий, которые принадлежат их разделу кода.
· Тестировщики могут отслеживать состояния и решения запросов изменения, чтобы проверить качество программного обеспечения.
· Руководители проекта и администраторы могут быстро получать информацию, помогающую им распределить ресурсы разработки, организовывать поток работ и точно определять даты выпуска.
· Администраторы могут интегрировать ClearQuest с существующими инструментальными средствами и настраивать его, чтобы приспособить к потоку работ вашей организации.
Это руководство дает краткий обзор того, как использовать ClearQuest в работе, и краткий пример того, как ваш администратор ClearQuest может настраивать его для приспособления вашего потока работ. За инструкциями по установке ClearQuest обратитесь к руководству Инсталляция Rational ClearQuest, которое поставлено с вашей программой.
Что такое ClearQuest?

ClearQuest состоит из нескольких компонентов, которые работают в среде клиент-сервер.

	Компонент
	Кто использует
	Для чего использует

	Инструменты для клиента

	ClearQuest для Windows
	Все
	Представление, модификация и отслеживание запросов изменения, и анализ продвижения проекта при выполнении запросов, диаграмм и отчетов.

	ClearQuest для UNIX
	Все
	Представление, модификация и отслеживание запросов изменения, и анализ продвижения проекта при выполнении запросов.

	ClearQuest Web
	Все
	Обращение к ClearQuest из других платформ через Netscape Navigator® или Microsoft’s Internet Explorer®. 

Представление запросов изменения и выполнение запросов. На Windows Вы можете также выполнять диаграммы и отчеты.

	Инструменты для администратора

	ClearQuest Designer
	Администратор ClearQuest
	Настройка ClearQuest, управление схемами и базами данных ClearQuest, пользователями и группами пользователей.

	ClearQuest Import Tool
	Администратор ClearQuest
	Импорт данных, включая отчеты, хронологию и запросы изменения от других связанных систем.

	ClearQuest Export Tool
	Администратор ClearQuest
	Экспорт данных ClearQuest из одной пользовательской базы данных в другую пользовательскую базу данных, которая использует другую схему.

	ClearQuest Maintenance Tool
	Все
	Установка и соединение с репозиторием схем при инсталляции и при модификации к новой версии ClearQuest.

	Rational E-mail Reader
	Администратор ClearQuest
	Конфигурирование параметров настройки вашей электронной почты, чтобы позволить пользователям ClearQuest представлять и изменять отчеты электронной почтой.
См. Главу 9, Администрирование электронной почтой ClearQuest.


Готовое к использованию управление запросами изменения
ClearQuest содержит несколько схем, которые предоставляют готовые к использованию процессы отслеживания изменений и дефектов и интеграцию с различными программными изделиями Rational. Вы можете использовать схемы ClearQuest как есть, или настраивать их, чтобы приспособить к процессам вашей компании. Для просмотра списка схем ClearQuest, см. раздел "Выбор схемы ClearQuest" на странице 25.
Поддержка вашей среды разработки
ClearQuest обеспечивает следующую поддержку для вашей среды разработки программного обеспечения:
Поддерживает реляционные базы данных Microsoft Access® (включается в ClearQuest), Sybase SQL Anywhere (включается в ClearQuest), Microsoft SQL Server®, Oracle и IBM DB2.
· Интегрирован с Rational ClearCase и Microsoft Visual SourceSafe, так что Вы можете сопоставить запросы изменения непосредственно с изменениями в программном обеспечении.
· Интегрирован с Rational TeamTest, VisualTest, Purify, PureCoverage и Quantify, позволяя Вам проверять запросы изменения ClearQuest непосредственно из этих инструментальных средств тестирования.
Включает Seagate’s Crystal Reports Professional EditionTM, так что Вы можете создавать настраиваемые отчеты из данных ClearQuest.
· Позволяет Вам интегрироваться с другими стандартными инструментальными средствами Windows, типа Microsoft Excel и Word через расширенный интерфейс COM.
· Обеспечивает доступ к Rational Unified Process через меню ClearQuest Help > Rational Extended Help.
· Поддерживает Microsoft IIS web server.
Где получить подробную информацию
ClearQuest включает следующую документацию:
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Работа с ClearQuest

Эта глава предназначена для всех пользователей ClearQuest. Она вводит основные концепции использования ClearQuest, включая информацию относительно того как:
· Представлять запрос изменения
· Работать с запросами изменений
· Отслеживать запросы изменений
· Собирать проектные метрики
[image: image37.png]


Если вы читаете эту главу как администратор ClearQuest, ищете значок "ClearQuest Designer" рядом с предложениями о том, как настраивать ClearQuest, чтобы приспособить потоки работ вашей организации. Для получения дополнительной информации прочитайте главу "Администрирование и настройка ClearQuest" на странице 15.
Примечание: примеры в этой главе относятся к схеме DefectTracking и базе данных SAMPL, которые поставляются с ClearQuest. Они представляют только одну модель использования ClearQuest. Для получения дополнительной информации, см. раздел "Выбор схемы ClearQuest" на странице 25.
Быстрое начало

Для начала использования ClearQuest:

1. Выберите Rational ClearQuest в меню Start.

2. Войдите в ClearQuest. Вы можете использовать встроенное имя пользователя ClearQuest (admin). Вам не нужно печатать пароль.

Выберите базу данных SAMPL, чтобы экспериментировать с рабочей пользовательской базой данных, которая уже содержит много записей запросов изменений.
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В течение инсталляции Вы создадите и сконфигурируете пользовательские базы данных для вашей группы. Их названия будут появляться в раскрывающемся списке баз данных. См. руководство Инсталляция Rational ClearQuest. Вы используете ClearQuest Designer, чтобы установить учетные записи для входа в систему пользователей и определить права их доступа. См. главу 6, "Администрирование пользователями" в руководстве Администрирование Rational ClearQuest.
Продолжение знакомства с ClearQuest

Главное окно ClearQuest содержит рабочую область (Workspace), компоновщик запросов (Query Builder) и форму записи (Record form).
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Папка Public Queries в рабочей области содержит запросы, диаграммы и отчеты, включенные в ClearQuest и те, которые создает ваш администратор ClearQuest. Вы можете перетаскивать любой запрос, диаграмму или отчет в вашу папку Personal Queries и изменять их, чтобы удовлетворить свои потребности.
Вы можете нажать Print, чтобы напечатать единичный отчет. Чтобы сделать это, Вы должны связать формат отчета с типом записей. Просмотрите раздел Print Single Record в оглавлении справочной системы ClearQuest Designer.
Подробная информация? Выберите Help > Contents > Getting around ClearQuest.

Представление запроса изменения
Вы начинаете использовать ClearQuest с представления запроса изменения. В результате этого действия в базе данных пользователя создается запись, по которой каждый член группы может прослеживать, как развивается ваша разработка и испытание.
Чтобы представить запрос изменения, нажмите [image: image4.png]&3 New defect
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Используйте закладки в окне Submit Defect, чтобы подробно описать запрос изменения, включая связанные фрагменты кода и другую информацию поддержки. Некоторые закладки содержат поля, которые являются обязательными. Например, в поле Headline нужно ввести короткое предложение, описывающее проблему, и Вы должны выбрать значение для поля Severity (Сложность).
Вы можете сохранять часто используемые значения полей как значения по умолчанию, так что Вы не должны снова вводить их каждый раз, когда Вы представляете запрос изменения. Заполните поля, которые Вы хотите сохранить и выберите Values > Save as Default.
Примечание: В ClearQuest Вы можете также представить запрос изменения непосредственно из Rational TeamTest, Purify, PureCoverage, Quantify и Visual Test. Для представления и модификации запросов изменения Вы можете использовать ClearQuest Web и ClearQuest UNIX или представлять запросы изменения по электронной почте.
Как администратор ClearQuest, Вы можете создавать дополнительные типы записей. Например, Вы могли бы создать отдельные типы записей для аппаратных дефектов, программных дефектов и для запросов расширения. Вы можете, также, настраивать формы записей, включая добавление закладок и полей и определение их поведения. См. главу 5, "Настройка схемы" в руководстве Администрирование Rational ClearQuest.
Подробная информация? Выберите Help > Contents > Working with records.

Прием автоматического уведомления электронной почтой

Ваш администратор может конфигурировать ClearQuest так, чтобы автоматически рассылать электронную почту другим членам группы, когда представлен или изменен запрос изменения. Чтобы воспользоваться преимуществом автоматического уведомления электронной почты, все пользователи ClearQuest должны установить параметры своей электронной почты. Выберите View > E-mail Options.
Подробная информация? Выберите Help > Contents > Using ClearQuest > Setting up e-mail notification.
Тип записи Email_rule облегчает определение правил для посылки автоматического уведомления электронной почты пользователям ClearQuest. Тип записи Email_rule – это часть пакета E-mail, включенного в каждую схему "из коробки" ClearQuest. Вы можете также использовать Rational E-mail Reader для конфигурирования параметров настройки вашей электронной почты так, чтобы пользователи ClearQuest могли представлять и модифицировать отчеты электронной почтой.
Подробная информация? В ClearQuest Designer выберите Help > Contents > Using e-mail features. Читайте главу 9, "Администрирование электронной почты ClearQuest" в руководстве Администрирование Rational ClearQuest.
Работа с записями запросов изменений
Вы работаете с записями запросов изменений, перемещая их через различные стадии, или "состояния". В каждом состоянии Вы можете выполнять действия типа модификации записи или перемещения ее в другое состояние. Меню Actions перечисляет действия, которые Вы можете выполнять с записью, когда она находится в любом возможном состоянии.
Ниже приводится пример типичного потока работ:
Назначение запроса изменения
Запись запроса изменения обычно начинается из состояния Submitted (представлена). Первое необходимое действие состоит в назначении запроса изменения инженеру, ответственному за этот раздел кода.
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Действие Assign изменяет состояние записи на Assigned (назначена).
Точный процесс работы с записями, включая возможные состояния записей и возможные действия, доступные в каждом состоянии, зависит от схемы ClearQuest, которую Вы используете и от настроек, которые Вы для него установили. См. раздел "Настройка схемы" на странице 16.
Модификация запроса изменения
Не все действия изменяют состояние запроса изменения. Вы можете выбрать Actions > Modify, чтобы изменить некоторую информацию по запросу изменения без фактического изменения его состояния.
Открытие и разрешение запроса изменения
Если Вы - инженер, которому предназначен запрос изменения, Вы начинаете работу,  выбирая Actions > Open. Это действие изменяет состояние записи на Opened (открыта); теперь остальная часть группы может видеть, что вы работаете над проблемой.
Когда Вы закончите вашу работу, выберите Actions > Resolve, чтобы изменить состояние записи на Resolved (разрешена).
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В этом примере администратор сконфигурировал ClearQuest так, чтобы послать автоматическое уведомление электронной почты группе обеспечения качества (Quality Assurance) как часть действия Resolve. После этого инженер обеспечения качества может проверить, что проблема устранена, и изменить состояние записи в Closed (закрыта).
Как администратор ClearQuest, Вы можете ограничить действия определенным группам пользователей. Например, Вы могли бы позволить членам всех групп разрешать запросы изменений, но действие Verify (проверка) разрешить только членами группы обеспечения качества.
Отслеживание записей запросов изменений

Каждый член вашей группы может отслеживать продвижение записей запросов изменений в вашей системе.
Использование общих запросов

ClearQuest содержит готовые к использованию запросы, которые помогают Вам искать записи по проектам или компонентам, по назначенным инженерам, уровню сложности и так далее. Например, когда Вы обнаружите дефект в вашем программном обеспечении, Вы можете выяснить, был ли он уже представлен. Выберите Public Queries > All Defects, чтобы отобразить все записи в базе данных, или используйте запрос поиска по ключевым словам (Keyword search), чтобы найти записи, содержащие определенное слово в поле Headline или Description.
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В течение сеанса представления новых дефектов Вы можете выбрать Query > RecentlySubmitted, чтобы просмотреть список дефектов, которые Вы представили с момента входа.
Модификация запросов

Для изменения запроса его сначала перетаскивают в вашу персональную папку запросов, а затем используют закладки Query editor и Display editor.
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Формирование нового запроса
Чтобы сформировать новый запрос на пустом месте или из существующего запроса, выберите Query > New Query. Шаги мастера запроса ClearQuest проведут Вас через процесс формирования запроса.
Подробная информация? Выберите Help > Contents > Working with queries.
Как администратор ClearQuest, Вы можете сохранять запросы в папке Public Queries и можете разрешить эту возможность другим пользователям. См. главу 6, "Администрирование пользователями" в руководстве Администрирование Rational ClearQuest.
Сбор проектных метрик
ClearQuest обеспечивает предопределенные диаграммы и отчеты, которые Вы можете выполнять на Windows и на ClearQuest Web, чтобы рассмотреть состояние вашего проекта. На Windows Вы можете изменять эти диаграммы и отчеты, чтобы приспособить их к вашим потребностям. ClearQuest UNIX не поддерживает создание диаграмм или отчетов. 
Использование диаграмм ClearQuest

ClearQuest отображает данные записей на диаграмме в графической форме: Диаграммы распределения показывают текущее состояние данных, в то время как диаграммы тенденций и возраста показывают историческую информацию.
Например, Вы можете видеть, как распределена рабочая нагрузка среди членов вашей группы,  выполняя диаграмму распределения, которая отображает дефекты, назначенные каждому работнику. Или, Вы можете видеть график записей дефектов с их состоянием и сложностью.
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Для изменения содержания диаграммы есть два способа: Выберите Edit > Properties, чтобы определить, как отображать данные, или используйте закладку Query editor, чтобы фильтровать записи, включаемые в диаграмму.
Создание отчета из данных ClearQuest
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ClearQuest содержит отчеты и форматы отчетов, которые Вы можете использовать для создания отчетов из данных ClearQuest. Для создания отчета относительно текущего набора результатов запроса, сначала выполняют запрос типа All Defects, затем нажимают  [image: image12.png]


, чтобы открыть диалоговое окно Create Report.

Это действие создает отчет в выбранном формате из данных в наборе результатов запроса. Нажмите  [image: image13.png]


, чтобы экспортировать вывод отчета в другой формат, типа HTML или Excel.
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Для создания нового отчета, который Вы сможете многократно использовать, выполните запрос, из которого Вы хотите создать отчет, а затем выберите Query > New Report.
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Выберите формат отчета, а затем сопоставьте формат с запросом.
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Это действие создает отчет из данных запроса, который Вы выбрали. Вы можете сохранить этот отчет в вашей папке персональных запросов и выполнять его в любое время.
Вы можете использовать Crystal Reports Professional Edition для создания новых форматов отчетов. Вы можете сохранять эти форматы в вашей папке персональных запросов и использовать их для форматирования отчетов ClearQuest.
Подробная информация? См. Help > Contents > Working with reports.
Теперь вы готовы начинать работать с ClearQuest. Помните, что справка ClearQuest содержит подробную информацию, которая поможет Вам на любом шаге Вашего пути. Для контекстно-зависимой справки, нажмите  [image: image17.png]


, а затем нажмите элемент, относительно которого Вы хотите получить информацию.
Убедитесь, что Вы читали следующую главу, "Администрирование и настройка ClearQuest"
Администрирование и настройка ClearQuest

Эта глава предназначена для администраторов ClearQuest. Она начинается с краткого обзора баз данных и схем ClearQuest, а затем приводит краткий пример того, как выполнить первичную задачу администратора — настроить схему ClearQuest для приспособления вашего процесса.
Примечание: Для получения полной информации относительно администрирования ClearQuest, включая описание того, как назначать и изменять пользователей ClearQuest, смотрите руководство Администрирование Rational ClearQuest, которое поставляется с вашей копией ClearQuest. Чтобы выполнить учебную программу, выберите ClearQuest Designer Tutorial из меню Start.
Краткий обзор баз данных и схем ClearQuest 
Схема ClearQuest содержит метаданные, которые определяют процесс того, как ваши пользователи ClearQuest работают с записями. Она включает:
· Определения типов записи
· Формы, используемые для представления и изменения записей
· Определения полей и поведения
· Состояния, в которых может находиться записи
· Действия, используемые для модификации или изменения состояния записей
· Обработчики прерываний, написанные на Visual Basic ScriptTM или Perl, для дальнейшей настройки полей и действий.
Примечание: ClearQuest включает несколько предопределенных схем, которые Вы можете использовать "как есть" или настраивать для приспособления к вашим процедурам. Список этих схем содержится в разделе "Выбор схемы ClearQuest" на стр. 25.
ClearQuest хранит схемы в репозитории схем. Инсталляция ClearQuest обычно состоит из одного репозитория схем и одной или большего числа пользовательских баз данных. Вы можете использовать отдельную базу данных для каждого проекта, или одну базу данных для группы из несколько проектов. Если Вы хотите генерировать отчеты и диаграммы для группы проектов, Вы должны поместить проекты в одну базу данных. Проекты, содержащиеся в базе данных, должны использовать одну и ту же схему.
На иллюстрации ниже представлен пример того, как репозиторий схем с двумя схемами может работать с несколькими различными базами данных пользователя:
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Примечание: После того, как база данных связана со схемой, она может быть модернизирована только более новыми версиями той же самой схемы. Она не может использовать старшие версии схемы или полностью другие схемы.
В представленном выше примере Вы можете:
· Модернизировать базы данных для проектов X, Y или Z более новыми версиями схемы DefectTracking.
· Модернизировать тестовую базу данных Test более новыми версиями схемы myschema.
· Применить любую версию схем DefectTracking или myschema к новой базе данных.
Подробная информация? Полное описание того, как работать со схемами и базами данных, см. в главе 4, "Работа со схемами ClearQuest" руководства Администрирование Rational ClearQuest.
Запуск ClearQuest Designer

Для запуска ClearQuest Designer:

1. В меню Start выберите ClearQuest Designer.

ClearQuest определяет имя пользователя по умолчанию (admin), которое Вы можете использовать для начала работы. Вы не должны печатать пароль. Учетная запись администратора пользователей дает Вам возможность исполнять все функции администратора ClearQuest. Для изменения учетной записи администратора выберите Tools > User Administration, затем выберите пользователя admin и нажмите Edit.
Подробная информация? См. главу 6, "Администрирование пользователями" в руководстве Администрирование Rational ClearQuest..
2. ClearQuest Designer отображает диалоговое окно Open Schema. Выберите Check out a schema, если Вы планируете изменить ее, и нажмите Finish; иначе нажмите Cancel для продолжения.

[image: image19.png]tep 1 0 2

HasxauTe 4017 HameHeHHA
cxemel N Eheckoit s 5chains (55dit &

{continse eding reviously saved work

 Yiewa verson of an ewstingschena.

BuiBepuTe ciety

HasxwiTe 4017 HameHeHI

Cxem

Sohers [ Lo [Creted| st
Nome |Vl G| o
4| N
q T
V' Show this wizard at startup
o] o | v

Haskwre gn1a sanycka
ClearQuest Designer Bes

WEMEHEHUA CHEMbI





Настройка схемы

Этот раздел предоставляет краткий пример того, как настроить схему, чтобы приспособить процесс потока работ. Предположим, что Вы имеете простую запись о дефекте, которая может находиться только в двух состояниях: Submitted (Представлена) и Closed (Закрыта) и над которой выполняются три действия: Submit (Представление), Modify (Изменение) и Resolve (Решение). Процесс работы с этой записью продемонстрирован следующей моделью состояний:
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Запись о дефекте появляется в состоянии Представлена; далее Вы можете выбрать Actions > Resolve (Решение), чтобы изменить состояние записи на Закрыта или Actions > Modify (Изменение), чтобы изменить содержание записи без изменения ее состояния. Форма записи напоминает следующую:
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Процесс работы с записью, форма и поля записи определяются схемой ClearQuest.
В следующем примере Вы измените процесс работы с записью о дефекте,  добавляя состояние Opened (Открыта) так, чтобы модель состояний напоминала следующую:
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Чтобы настроить схему и реализовать этот новый процесс, Вы должны:
· Добавить новое состояние Opened (Открыта) между состояниями Submitted (Представлена) и Closed (Закрыта).
· Добавить новое действие Open (Открытие), которое изменяет состояние записи из состояния Submitted (Представлена) в состояние Opened (Открыта).
· Добавить поле planned_fix_date к форме записи.
· Определить поведение поля planned_fix_date.
· Создать на Visual Basic обработчик прерываний, который автоматически заполнит поле planned_fix_date.
"Извлечение" схемы

Для настройки схемы Вы должны сначала "извлечь" ее из репозитория схем. Выберите File > Open Schema. Полное описание команд по работе со схемами, включая установку тестовой базы данных, и рекомендации по проверке настроек схемы содержатся в главе 4, "Работа со схемами" руководства Администрирование Rational ClearQuest.
Добавление нового состояния

Матрица переходов состояний (State Transition Matrix) ClearQuest Designer показывает различные состояния, в которых может находиться запись, и действия, которые переводят запись из одного состояния в другое. В этом примере она показывает, что действие Решение (Resolve) переводит запись из состояния Представлена (Submitted) в состояние Закрыта (Closed).
Чтобы добавить новое состояние откройте матрицу переходов состояний, а затем выберите Edit > Add State.
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Подробная информация? Просмотрите states, creating в оглавлении справочной системы ClearQuest Designer.
Добавление нового действия

Таблица Actions показывает все действия, которые могут быть выполнены над записью. Чтобы добавить новое действие, Вы сначала добавляете действие в таблицу Actions, а затем сопоставляете его с соответствующими состояниями.
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Таким образом, Вы добавили действие Open к меню Actions ClearQuest. Теперь, когда запись находится в исходном состоянии (Submitted), Вы можете выбирать Actions > Open для перевода записи в новое состояние (Opened).
Кроме того, Вы должны изменить существующее действие Resolve (Решение), чтобы добавить Opened (Открыта) как допустимое исходное состояние.
Подробная информация? Просмотрите actions, adding в оглавлении справочной системы ClearQuest Designer.
Еще раз посмотрите на матрицу переходов состояний. Теперь она показывает, что действие Open переводит запись из состояния Submitted в состояние Opened, как Вы того хотели.
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Вы можете посмотреть, как матрица переходов состояний реализует модель состояний.
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В состоянии Представлена Вы можете выбирать Actions > Open, чтобы перевести запись в состояние Открыта, или Actions > Resolve, чтобы перевести запись в состояние Закрыта.
Подробная информация? Посмотрите state transitions в оглавлении справочной системы ClearQuest Designer.
Создание нового поля

Теперь нужно создать в форме записи новое поле planned_fix_date, которое позволит Вам вводить установленную дату закрытия дефекта.
Для создания нового поля откройте таблицу Fields. Таблица Fields показывает все полям формы записи, их тип и значения по умолчанию.
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Подробная информация? Просмотрите fields, adding to schemas в оглавлении справочной системы ClearQuest Designer.
Определение поведения нового поля
Таблица Behaviors показывает, как ведут себя поля, когда запись находится в каждом конкретном состоянии. Вы можете указывать, предоставляется ли поле только для чтения, обязательно оно или необязательно в каждом состоянии, или определять заданное по умолчанию поведение для всех состояний. Вы можете также создавать обработчик прерываний, который ограничивает доступ пользователя к полю. За дополнительной информацией обратитесь к руководству Справочник ClearQuest API.
Откройте таблицу Behaviors, затем щелкните правой кнопкой мыши и используйте всплывающее меню, чтобы определить поведение поля planned_fix_date.
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Подробная информация? Просмотрите fields, behaviors в оглавлении справочной системы ClearQuest Designer.
Добавление нового поля к форме записи

После создания поля, Вы должны добавить его к форме записи. Для добавления поля planned_fix_date к форме записи откройте форму Defect. В рабочей области выберите Record Types > Defect > Forms > Defect.
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Когда Вы заканчите, закройте окно формы.
Подробная информация? Просмотрите controls, adding to forms в оглавлении справочной системы ClearQuest Designer.
Создание обработчика прерываний для действия
Обработчики прерываний – это триггеры для частей кода, которые ClearQuest выполняет в нужный момент для более полного обеспечения вашего процесса. ClearQuest предоставляет много общих обработчиков прерываний, которые Вы можете легко изменять для удовлетворения ваших потребностей. Кроме того, Вы можете использовать интерфейс прикладного программирования (API) ClearQuest для написания кода обработчика прерываний на Microsoft VBScript или Perl.
ClearQuest поддерживает четыре типа кода обработчика прерываний:
· Обработчики прерываний полей обеспечивают способ проверить правильность содержания поля или назначить значение полю.
· Обработчики прерываний действий выполняют задания в ключевых пунктах жизненного цикла записи.
· Сценарии записи позволяют Вам сопоставлять обработчик прерываний с управлением, типа кнопочного переключателя или выбора из контекстного меню, для одной записи.
· Глобальные сценарии позволяют Вам многократно использовать код обработчика прерываний в других обработчиках прерываний.
В следующем примере Вы измените предопределенный обработчик прерываний ACTION_INITIALIZATION для действия Open так, чтобы он инициализировал значение поля planned_fix_date.
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Эти действия открывают редактор ClearQuest Script Editor.
Используйте ClearQuest Script Editor для редактирования обработчика прерываний ACTION_INITIALIZATION так, чтобы он устанавливал значение поля planned_fix_date равным текущей дате + три дня.
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Подробная информация? Просмотрите hooks, overview в оглавлении справочной системы ClearQuest Designer. Прочитайте главу 7, "Использование обработчиков прерываний для настройки потока работ" в руководстве Администрирование Rational ClearQuest.
"Возвращение" схемы

В любое время при работе над схемой Вы можете выбрать File > Test Work, чтобы протестировать вашу работу. Это действие модернизирует тестовую базу данных вашими самыми последними изменениями, обеспечивая возможность быстро проверить вашу работу с позиции пользователя ClearQuest.
Когда вы убедились, что ваши изменения схемы работают правильно, выберите File > Check in, чтобы "возвратить" схему в репозиторий схем. После того, как схема "возвращена" в репозитории, Вы можете использовать ее для модернизации вашей базы данных пользователя. Выберите Database > Upgrade Database. ClearQuest запрашивает Вас о необходимости резервного копирования репозитория схем и базы данных перед обновлением.
Подробная информация? Прочитайте главу 4, "Работа со схемами" в руководстве Администрирование Rational ClearQuest.
Работа с новой формой записи
После обновления пользовательской базы данных с использованием настроенной схемы, форма записи о дефекте работает подобно следующей:
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Действие Open изменяет состояние записи на Opened и автоматически заполняет поле planned_fix_date.
[image: image35.png]Mone planned_i_date
anoni
aEToMATHECKH





Выбор схемы ClearQuest

Ниже представлен список предопределенных схем, которые включены в ClearQuest. Схемы ClearQuest состоят из различных пакетов, которые обеспечивают определенные функциональные возможности. Вы можете добавлять индивидуальные пакеты к существующей схеме ClearQuest или к вашей собственной настроенной схеме. Полное описание схем и пакетов ClearQuest содержится в руководстве Администрирование Rational ClearQuest.
	Схема 
	Описание

	AnalystStudio
	Совместима с Rational Suite Analyst Studio. Содержит настройку для использования с Rational RequisitePro.

	Blank
	Содержит только системные поля. Используйте эту схему для создания схемы на пустом месте.

	Common
	Содержит метаданные, которые является общими для всех схем ClearQuest.

	DefectTracking
	Содержит поля, необходимые для начала использования ClearQuest для отслеживания дефектов в среде разработки программного обеспечения.

	DevelopmentStudio
	Совместима с Rational Suite DevelopmentStudio. Содержит поля и правила для работы с Rational Purify, Quantify и PureCoverage.

	Enterprise
	Для использования с Rational Suite EnterpriseStudio. Содержит поля и обработчики прерываний, которые работают со всеми программами Rational.

	TestStudio
	Совместима с Rational Suite TestStudio. Содержит поля и правила для работы с Rational TeamTest, RequisitePro, Purify, Quantify и PureCoverage.

	UnifiedChangeManagement 
	Поддерживает процесс UCM,  обеспечивая интеграсию с Rational ClearCase.


Теперь Вы готовы начать использовать ClearQuest Designer. Помните, что  справочная система ClearQuest Designer содержит подробную информацию, помогающую Вам на каждом шаге вашего пути. Для получения контекстно-зависимой справки, нажмите кнопку [image: image36.bmp], а затем нажмите элемент, о котором Вы хотите получить информацию.
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